Difference between revisions of "User guide/fr"

From Kiwix
Jump to navigation Jump to search
(Created page with "Mode d'emploi")
 
 
(49 intermediate revisions by 5 users not shown)
Line 3: Line 3:
<div style="margin-bottom:8px; border:2px solid #dfdfdf; padding:1em; background-color:#bcd4e6; -moz-border-radius:15px; -webkit-border-radius:15px;">
<div style="margin-bottom:8px; border:2px solid #dfdfdf; padding:1em; background-color:#bcd4e6; -moz-border-radius:15px; -webkit-border-radius:15px;">
<big>
<big>
'''User Guide'''
'''Mode d'emploi'''
<br>
<br>
A brief instruction includes information on the application's tools and commands ...  
Une brève instruction incluant des informations sur les outils et commandes de l'application ...  
</big>
</big>
<br>
<br>
'''[[Help|← Back to help page]]'''
'''[[Special:MyLanguage/Help|← Retour à la page d'aide]]'''
</div>
</div>
</div>
</div>
Line 14: Line 14:
<div style="width:99%; float:center"; align=left>
<div style="width:99%; float:center"; align=left>
<div style="margin-bottom:8px; border:2px solid #dfdfdf; padding:1em; background-color:#eedae3; -moz-border-radius:15px; -webkit-border-radius:15px;">
<div style="margin-bottom:8px; border:2px solid #dfdfdf; padding:1em; background-color:#eedae3; -moz-border-radius:15px; -webkit-border-radius:15px;">
;*Navigation keys and buttons
== Les touches de navigation et les boutons ==
:Browsing Kiwix content is in a similar way as the web-browsers, so you can easily navigate from a page (which could be a document or an article) to another page. Click on the '''Home''' icon [[File:home24.png|link=]] will take you to your current ZIM file's homepage. For instance, if you run the English Wikipedia ZIM file, you will see the [[Wikipedia]] entry as its homepage. If you haven't installed any ZIM file yet, you will see the [[Help|Help page]] as the homepage and it means there is no content to display. In that case, you should follow the instructions of [[Wikipedia in all languages|this page]] in order to read the content.
La manière de parcourir le contenu de Kiwix est similaire à un navigateur web, ainsi vous pouvez facilement naviguer à partir d'une page (qui pourrait être un document ou un article) vers une autre page. Cliquez sur l’icône '''Page d'accueil''' [[File:home24.png|link=]] si vous voulez vous rendre sur la page d'accueil de votre fichier ZIM actuel. Par exemple, si vous démarrez le fichier ZIM Wikipédia en français, vous verrez l'entrée [[Special:MyLanguage/Wikipedia|Wikipédia]] sur votre page d'accueil. Si vous n'avez pas encore installé un fichier ZIM, vous verrez la [[Special:MyLanguage/Help|page d'aide]] sur la page d'accueil et cela signifie qu'il n'y a pas de contenu à afficher. Dans ce cas, vous devez suivre les instructions de [[Special:MyLanguage/Wikipedia in all languages|cette page]] pour lire du contenu.
:Just like your web-browser, you can return previous page by clicking on '''Back''' arrow icon [[File:Go-back24.png|link=]] and go to the next page by clicking on '''Forward''' arrow icon [[File:go-forward24.png|link=]] in the toolbar. To open the ''New Tab'' page, click on the '''Open a new tab''' icon [[File:add24.png|link=]] next the last tab at the top of window or press '''Ctrl+T''' ('''⌘-T''' on Mac). To close a tab, use the [[File:close12.png|link=]] in the right side of each tab you want to close or keyboard shortcuts '''Ctrl+W''' and ('''⌘-W''' on Mac). You can open the links of a page in a new tab, by pressing '''Ctrl''' on your keyboard or right clicking on the link and choose "Open link in new Tab" then.


;*Adjust the size of the text
Comme pour votre navigateur web, vous pouvez retourner à la page précédente en cliquant sur l'icône de flèche '''Précédente''' [[File:Go-back24.png|link=]] et aller à la page suivante en cliquant sur l'icône de flèche '''Suivante''' [[File:go-forward24.png|link=]] dans la barre d'outils.
:The size of the text is specified by the content package you are using. Because it might not be ideal for your eyes and comfort, you can either increase or decrease the text size of the pages at any time. To do so, use the '''Magnify''' icon [[File:zoom-in24.png|link=]] to increase and '''Reduce''' icon [[File:zoom-out24.png|link=]] to decrease the size of the text. Those commands are also available in '''Display > Zoom''' on the menu bar and one more option named [[File:zoom-10016.png|link=]]'''Original size''' is there which reset the text size of the page to its original size. You can also use the keyboard shortcuts '''Ctrl''' and '''+''' ('''⌘''' and '''+''' on Mac) to zoom in, '''Ctrl''' and '''-''' ('''⌘''' and '''-''' on Mac) to zoom out and '''Ctrl''' and '''0''' ('''''' and '''0''' on Mac) to reset the zoom tool.
Pour ouvrir une page '''Nouvel onglet''', cliquez sur l'icône '''Ouvrir un nouvel onglet''' [[File:add24.png|link=]] à côté du dernier onglet ouvert.
:In order to gain some extra space on a small display, you may wish to display Kiwix in full-screen mode, it will maximize the size of the Kiwix window and hide all other programs including your operating system. In order to do this, click on '''full-screen''' icon [[File:fullscreen24.png|link=]] or use the keyboard shortcuts '''F11''' (on Windows and Linux) and '''⌘-Shift-F''' (on Mac).
Pour fermer un onglet, utilisez cliquez sur l'icône [[File:close12.png|link=]] sur le côté droit de l'onglet désiré.
;*Printing and exporting documents
Pour ouvrir un lien vers une autre page dans un nouvel onglet, faites un clic droit sur celui-ci, et choisissez "Ouvrir dans un nouvel onglet".
:You can print the Kiwix pages or even export them and share. There are three options available:
:#To print a page you are viewing in Kiwix, click on '''Print''' icon [[File:print24.png|link=]] in the toolbar or press '''Ctrl+P''' ('''⌘-P''' on Mac). This option is also available in '''File''' menu. You will be able to preview the page and adjust basic printer and page settings, before printing. Make sure the computer connected to the printer is also turned on.
:#To export a page to PDF format, go to '''File > [[File:printas-pdf16.png|link=]]Print as PDF''' menu item or just press '''Ctrl+Shift+D''' ('''⌘-Shift-D''' on Mac). It will convert the page into a PDF file which can be used to print or read the document later. Note that the output has been prepared for printing and the internal links will be removed from the page.
:#To save the page as an HTML or text file, go to '''File > [[File:saveas16.png|link=]]Save page as''' menu item or just press '''Ctrl+S''' ('''⌘-S''' on Mac). Although it is not appropriate for sharing, the HTML format will keep the same formatting and links of the page.


;*Create Bookmarks and use them
Raccourcis clavier:
:You can use Kiwix bookmarks to easily save the pages you would like to revisit. Bookmarks are organised in sets which is a list (or group) of bookmarks that has been put together. You can easily import/export a complete set of bookmarks, which is saved as a regular file on your computer, and you may wish to share a list of pages then, e.g. with your students.
*'''Ctrl''' et '''T''' ('''''' et '''T''' sur Mac): nouvel onglet
:Clicking on the '''Bookmarks''' icon [[File:bookmarks24.png|link=]] in the toolbar will show you the Bookmarks panel on the left side of the application. To create a new set, click on the '''Create new Bookmark Set''' icon [[File:new24.png|link=]] and then choose a path on your computer and type a name. It will saved as a .XML file and each time you add or delete a bookmark to the set, this file will be updated. You can share this file with someone or somewhere else to import or backup. If you have a Bookmark file and want to import it to your Kiwix, click on '''Import Bookmark Set''' icon [[File:open24.png|link=]] in top of th panel and then select the .XML file from your computer.
*'''Ctrl''' et '''W''' ('''⌘''' et '''W''' sur Mac): fermer l'onglet actuel
:You can add the current page to your bookmark set by clicking on '''Mark this page''' icon [[File:add24.png|link=]] or use the the keyboard shortcuts '''Ctrl+D''' ('''⌘-D''' on Mac). It will add to the Bookmark list and you can also write some notes for it in the bottom of the panel, '''Bookmark notes'''. Selecting each item of the list will navigate you to that page, and you may want to remove that item by clicking on '''Unmark selected''' icon [[File:remove24.png|link=]]. You can switch between your opened sets (default one and those you imported) using the combo list of opened bookmark sets below the panel toolbar. Once you close Kiwix, all your sets will be closed and you will need to import them again at the next time.
*'''Ctrl''' pendant clic ('''''' pendant clic sur Mac): ouvrir le lien dans un nouvel onglet


;* Edit tools
== Ajuster la taille du texte ==
:Use the find bar to locate a specific word or phrase on a webpage. To do so, click on the '''Find in text''' icon [[File:find-article24.png|link=]] in the toolbar or choose '''Edit > Search in page''' from menu bar. You can also use the keyboard shortcuts '''Ctrl+F''' ('''⌘-F''' on Mac) to quickly open the find bar. Kiwix automatically finds the page as you type, highlighting possible matches in green or see where all the matches are located on a page (in pink) by tapping on '''Highlight all''' button in the find bar. Switch between the search results using '''Next''' and '''Previous''' in the find bar and also choose '''Match case''' if you are going to have a case-sensitive search.
La taille du texte est spécifiée par le pack de contenu que vous utilisez. Pour votre confort visuel, vous pouvez augmenter ou diminuer la taille du texte quand vous le souhaitez.
:Kiwix also supports copy-pasting feature. In order to do that, select a part of the text using the mouse and then choose '''Edit > [[File:copy16.png|link=]]Copy''' or just press '''Ctrl+C''' ('''⌘-C''' on Mac) from your keyboard. You can also do a right click on the text and choose "Copy" to copy the text or "Search for" to search the text in the ZIM file. Then you will be able to paste that text in any other application you want. If you want the select the whole text of a page, choose '''Edit > [[File:select-all16.png|link=]]Select all''' or press '''Ctrl+A''' ('''⌘-A''' on Mac) from your keyboard, and also by right clicking in everywhere of the page and choosing "Select all".
Pour ce faire, utilisez l'icone '''Augmenter''' [[File:zoom-in24.png|link=]] pour augmenter et '''Diminuer''' [[File:zoom-out24.png|link=]] pour diminuer la taille du texte. Ces commandes sont aussi disponibles dans la barre de menu, '''Affichage>Zoom''', ainsi que l'option '''Taille originale''' pour réinitialiser le texte à sa taille originale.


Raccourcis clavier:
*'''Ctrl''' et '''+''' ('''⌘''' et '''+''' sur Mac): augmenter la taille du texte
*'''Ctrl''' et '''-''' ('''⌘''' et '''-''' sur Mac): diminuer la taille du texte
*'''Ctrl''' et '''0''' ('''⌘''' et '''0''' sur Mac): réinitialiser la taille du texte


;*Full-text search engine and Indexing process
Pour gagner de l'espace sur un écran réduit, il peut être souhaitable d'afficher Kiwix en mode plein écran. Pour ce faire, cliquez sur l'icône '''Plein écran'''[[File:fullscreen24.png|link=]] ; pour quitter le mode plein écran, cliquez une deuxième fois sur cet icône.
[[File:Search-engine.png|thumb|300px|Using search engine Autocompletion feature. You can see the page titles stared with the word "Wikipedia", and then access to the desired page by clicking on the corresponding item of the list. You can also see the pages which includes the word "Wikipedia" by choosing the last item of the list (''containing 'Wikipedia'...'')]]
:Kiwix includes a powerful search engine to help you easily access to the pages you are looking for and search a phrase through the content of the pages of a package. The full-text search engine is available only for the indexed ZIM files, it means if you have downloaded a [[Wikipedia in all languages|Portable pre-indexed ZIM]] file, you will be able to use this ability. But for the Non-indexed ZIM files, you should index them first.
:The search engine is located on the right side of the toolbar. If you can select the search box and type a word inside that, it means your search engine is ready to use. Otherwise, Kiwix will ask you if you want to index the ZIM file or not. You will need to confirm this process in order to use [[Features#Search_engine|full-text search engine feature]] or cancel it and use the program without this feature. This step is very time-consuming process and depending on your ZIM file size and also the speed of your computer, might last several hours or even several days for big packages like English Wikipedia. Note that there is a 20 to 100 percents difference in size between the indexed and non-indexed ZIM files and if you want to index a ZIM file, your computer will have to create the index files which their size is equal to the same difference of the indexed and non-indexed ZIM files, so be careful to do this process without turning your system down or closing the application. You can also see how many percents of the indexing process has been proceeded or remained in the progressive green bar on the Status bar (like [[File:Indexing-progress.png|link=]]), so your status bar should be active and do this appear that from '''Display''' menu if you can't see it now. Note that you won't need to do this long process if you download the Pre-Indexed ZIM file.
:After being this process completed, the full-text search engine will be ready to use, you will just need to type a text into the search field and then press '''Enter''' on your keyboard. A page includes a list of matching results will appear and you can access the one you want to view.
:If you don't want to use the full-text search ability, you can just type a word in the search box and see a list of the page titles stated with that word. The popup-list has the ability of Autocomplete and predicts the word being typed and suggests you the nearest page titles and you can choose the one you want subsequently.




;* More options
Raccourci clavier: *'''F11''' ('''⌘''' et '''Shift''' et '''F''' sur Mac): activer/désactiver plein écran.
:There are some more features available in Kiwix. You can change the language of the application to the one you want by going to '''Display > Language''' in the menu bar and choosing your desired language there, and also the skin of Kiwix by going to '''Display > Skin'''. By choosing '''Display > Inverted colors''' or pressing '''Ctrl+I''' ('''⌘-I''' on Mac), the colors of the page will be inverted, e.g. the black text will be white and the white background will be black, this may go along with a log in the program.
 
:Like the sidebar of [http://en.wikipedia.org Wikipedia], there is an option named '''[[File:select-all16.png|link=]]Random article''' in the '''Tools''' menu, which shows a random article of the ZIM content. Another option of this menu is '''[[File:purge-history16.png|link=]]Purge history''' which clear the history of the pages you visited and so the Back/Forward buttons will be inactive since then.
== Imprimer et exporter des documents ==
:If you have a local network and you want to share Kiwix with the clients of the network, you must go to '''Tools > Server''', click on '''Start''' button after selecting the port and then click on '''Load'''. Afterward, you will have the same Kiwix with less features in your network (simply in your web browser). You can read supplemental information in '''[[Kiwix-serve]]'''.
Trois options sont disponibles pour imprimer ou exporter des pages Kiwix:
*Pour imprimer la page consultée sur Kiwix, cliquez sur l'icône '''Imprimer''' [[File:print24.png|link=]]. Cette option est également disponible dans le menu "Fichier". Vous pourrez alors prévisualiser la page et ajuster les paramètres de base de l'impression. Assurez-vous que l'imprimante soit allumée et connectée à l'ordinateur.
 
Raccourci clavier: '''Ctrl''' + '''P''' ('''⌘''' + '''P''' sur Mac): Imprimer la page actuelle
*L'export au format PDF se fait dans le menu '''Fichier > [[File:printas-pdf16.png|link=]]Imprimer au format PDF'''. Cela convertira la page en un document PDF qui peut être imprimé ou consulté plus tard. Notez que la sortie a été préformatée pour l'impression et que les liens internes ont été supprimés de la page.
 
Raccourci clavier: *'''Ctrl''' + '''Shift''' + '''D''' ('''⌘''' + '''Shift''' + '''D''' sur Mac): Export PDF
*L'export d'une page au format texte ou HTML se fait dans le menu '''Fichier > Enregistrer sous...'''. Bien que non approprié pour le partage, le format HTML gardera le même formatage et les liens internes de la page.
 
Raccourci clavier: '''Ctrl''' + '''S''' ('''⌘''' + '''S''' sur Mac): Export texte/HTML
 
== Créer et utiliser des marque-pages ==
Vous pouvez utiliser les marques pages de Kiwix pour sauvegarder les pages que vous voulez revisiter.
Les marque-pages sont organisés en groupes. Vous pouvez facilement importer/exporter un groupe de marque pages, qui est sauvegardé comme fichier sur votre  ordinateur ; vous pourrez ensuite partager cette liste de pages, par exemple à vos étudiants.
 
Cliquez sur l'icône '''Marque-pages''' [[File:bookmarks24.png|link=]] dans la barre de menus pour ouvrir le panneau latéral de gestion des marque-pages sur la gauche de l'application.
 
Pour créer un nouveau groupe, cliquez sur l'icône '''Créer un nouveau groupe de marque-pages''' [[File:new24.png|link=]], puis choisissez un emplacement sur votre ordinateur ; renseignez enfin le nom.
 
Le groupe créé sera enregistré sous forme d'une fichier .XML, qui sera mis à jour à chaque ajout/suppression d'un marque-page. Vous pouvez utiliser ce fichier à des fins de partage ou de restauration.
Pour importer un groupe de marque pages, cliquez sur l'icône '''Importer un groupe de marque-pages''' [[File:open24.png|link=]] en haut du panneau, puis sélectionnez le fichier XML concerné sur votre ordinateur.
 
Vous pouvez ajouter la page actuelle à votre marque-pages en cliquant sur l'icône '''Marquer cette page''' [[File:add24.png|link=]]. Celle-ci va être ajoutée augroupe de marque-pages ; vous pouvez ajouter des note au bas du panneau, '''Notes de marque-pages'''.
Sélectionner un item du groupe vous amènera à ladite page.
Vous pouvez supprimer cette page en cliquant sur l'icône '''Supprimer le marque-pages''' [[File:remove24.png|link=]]. Vous pouvez également changer entre vos différents groupes (celui par défaut et ceux importés) en utilisant la liste de groupes sous le panneau outils.
La fermeture de Kiwix entraîne la fermeture de tous les groupes ; vous devrez donc importer à nouveau tous vos groupes la lors de la prochaine utilisation.
 
Raccourci clavier:
*'''Ctrl''' + '''D''' ('''⌘''' + '''D''' sous Mac): Ajouter/supprimer la page actuelle du groupe
 
== Outils d'édition ==
Utilisez la barre de recherche pour localiser un mot ou une phrase spécifique dans une page web. Pour faire ainsi, cliquez sur l'icône '''Rechercher dans la page''' [[File:find-article24.png|link=]] ou choisissez '''Éditer>Rechercher dans la page''' dans la barre de menu.
Kiwi trouve automatiquement la page pendant que vous tapez, surlignant la correspondances actuelle (en vert), ou en montrant où se trouvent toutes les correspondances se trouvant (en rose) sur la page à l'aide de l'option '''Surligner tout''' dans la barre de recherche.
Naviguez d'un résultat à l'autre à l'aide des flèches '''Suivant''' et '''Précédent''' dans la barre de recherche ; vous pouvez également activer la sensibilité à la casse dans la même barre.
 
 
Raccourci clavier:
*'''Ctrl''' + '''F'''('''⌘-H''' sous Mac): Rechercher dans la page
 
Kiwix supporte également la fonction copier-coller. Pour faire ainsi, sélectionnez le texte puis choisissez depuis le menu '''Édition>Copier'''. Vous pouvez aussi faire un clic droit, '''Copier''', ou encore "Rechercher pour trouver le texte dans le fichier ZIM". Vous pourrez alors coller le texte sélectionné dans n'importe quelle autre application.
Si vous voulez sélectionner l'intégralité du texte, choisissez dans le menu '''Édition>Sélectionner tout'''. Vous pouvez également effectuer un clic droit, puis '''Sélectionnez tout'''.
 
Raccourcis clavier:
*'''Ctrl''' + '''C'''('''⌘-C''' sur Mac): copier le texte sélectionné
*'''Ctrl''' + '''A'''('''⌘-A''' sur Mac): tout sélectionner
 
== Moteur de recherche à plein texte et processus d'indexation ==
[[File:Search-engine.png|thumb|300px|Utilisation de l'autocomplétion. Vous pouvez voir les titres de pages référencées avec le mot "Wikipédia", et accéder à la page désirée en cliquant sur l'item correspondant dans la liste. Vous pouvez aussi voir les pages contenant le mot "Wikipédia" en choisissant le dernier item de la liste ("contenant 'Wikipédia')..."]]
Kiwix inclut un moteur de recherche performant qui vous aide à accéder aisément aux pages que vous consultez et chercher une phrase dans le contenu des pages d'un paquet. Le moteur de recherche plein texte n'est disponible que pour les fichiers ZIM indexés.
Donc si vous avez téléchargé des fichiers [[Special:MyLanguage/Wikipedia in all languages|ZIM portables pré-indexés]], vous pourrez utiliser cette fonctionnalité. Pour les fichiers non indexés, vous devrez tout d'abord les indexer.
 
Le moteur de recherche est localisé sur le côté droit de la barre d'outils. Si vous pouvez sélectionner le champ de recherche et y taper un mot, alors le moteur de recherche est prêt à être utilisé.
Dans le cas contraire, Kiwix va vous demander si vous voulez indexer le fichier ZIM ou non. Vous devrez confirmer si vous voulez utiliser le [[Special:MyLanguage/Features#Search_engine|moteur de recherche à plein texte]] ou annuler si vous voulez utilisez le programme sans cette fonctionnalité.
 
Cette étape prend beaucoup de temps. En fonction de la taille de votre fichier ZIM et de la vitesse de votre ordinateur, cela peut prendre plusieurs heures à plusieurs jours pour des paquets comme Wikipedia en anglais. Notez qu'il y a une différence de taille de 20 à 100% de différence entre les fichiers ZIM indexés et non-indexés et que si vous choisissez d'indexer un fichier ZIM votre ordinateur devra créer un fichier d'indexation ton la taille est égale à la différence entre les fichiers ZIM indexés et non-indexés ; veillez donc durant cette étape à ne pas fermer l'application ni éteindre votre ordinateur.
 
Vous pouvez voir combien de pourcents de l'indexation ont été réalisés dans la barre de progression verte dans la barre d'état (comme [[File:Indexing-progress.png|link=]]) ; votre barre d'état devrait donc être active, et si ce n'est pas le cas, vous pouvez l'afficher dans le menu '''Affichage'''. Notez que vous n'aurez pas à faire ceci si vous avez téléchargé un fichier ZIM pré-indexé.
 
Après que cette étape soit complétée, le moteur de recherche est prêt à être utilisé. Vous aurez juste à taper du texte dans votre barre de recherche et appuyer sur '''Entrée'''.
Une page incluant les résultats de recherche s'affichera et vous pourrez accéder à la page que vous voulez consulter.
 
Si vous ne voulez pas utiliser cette fonctionnalité, tapez simplement un mot dans la barre de recherche et vous verrez une liste des titres de pages contenant ce mot. La liste pop-up a la capacité d'autocomplétion, prédisant le mot actuellement écrit et vous suggérant le titre de page le plus proche, vous permettant de choisir celui que vous voulez en conséquence.
 
== Plus d'options ==
Il y a d'autres options disponibles avec Kiwix. Vous pouvez changer la langue de l'application en choisissant '''Affichage>Langue''' dans la barre de menu et choisir la langue désirée.
Vous pouvez également changer l'apparence de Kiwix en allant sur '''Affichage>Apparence'''. En choisissant '''Affichage>Couleurs inversées''', la couleur des pages sera inversée, par exemple le texte noir deviendra blanc et l'arrière plan blanc deviendra noir.
 
Raccourci clavier:
*'''Ctrl''' + '''I''' ('''⌘''' + '''I''' sur Mac):
 
Comme pour la barre latérale de [http://en.wikipedia.org Wikipedia], il y a une option nommée '''[[File:select-all16.png|link=]] Article au hasard''', qui montre un article au hasard du contenu ZIM. Une autre option de ce menu est '''[[File:purge-history16.png|link=]] Effacer historique''', qui supprime l'historique des pages que vous avez visitées ; les boutons Précédent/Suivant seront donc inutiles à partir de ce moment.
 
Si vous avez un réseau local et que vous souhaitez partager Kiwix avec des clients de ce réseau, allez dans '''Outils>Serveur''', cliquez sur le bouton '''Start''' après avoir sélectionné le port et cliquez sur '''Charger'''.
Après ceci vous aurez une application Kiwix moins fonctionnelle sur votre serveur. Plus d'informations ici: '''[[Special:MyLanguage/Kiwix-serve|Kiwix-serve]]'''.
</div>
</div>
</div>
</div>

Latest revision as of 20:07, 23 May 2020

Other languages:
English • ‎español • ‎français • ‎italiano • ‎magyar • ‎русский • ‎فارسی • ‎中文(中国大陆)‎ • ‎日本語

Mode d'emploi
Une brève instruction incluant des informations sur les outils et commandes de l'application ...

← Retour à la page d'aide

Les touches de navigation et les boutons

La manière de parcourir le contenu de Kiwix est similaire à un navigateur web, ainsi vous pouvez facilement naviguer à partir d'une page (qui pourrait être un document ou un article) vers une autre page. Cliquez sur l’icône Page d'accueil Home24.png si vous voulez vous rendre sur la page d'accueil de votre fichier ZIM actuel. Par exemple, si vous démarrez le fichier ZIM Wikipédia en français, vous verrez l'entrée Wikipédia sur votre page d'accueil. Si vous n'avez pas encore installé un fichier ZIM, vous verrez la page d'aide sur la page d'accueil et cela signifie qu'il n'y a pas de contenu à afficher. Dans ce cas, vous devez suivre les instructions de cette page pour lire du contenu.

Comme pour votre navigateur web, vous pouvez retourner à la page précédente en cliquant sur l'icône de flèche Précédente Go-back24.png et aller à la page suivante en cliquant sur l'icône de flèche Suivante Go-forward24.png dans la barre d'outils. Pour ouvrir une page Nouvel onglet, cliquez sur l'icône Ouvrir un nouvel onglet Add24.png à côté du dernier onglet ouvert. Pour fermer un onglet, utilisez cliquez sur l'icône Close12.png sur le côté droit de l'onglet désiré. Pour ouvrir un lien vers une autre page dans un nouvel onglet, faites un clic droit sur celui-ci, et choisissez "Ouvrir dans un nouvel onglet".

Raccourcis clavier:

  • Ctrl et T ( et T sur Mac): nouvel onglet
  • Ctrl et W ( et W sur Mac): fermer l'onglet actuel
  • Ctrl pendant clic ( pendant clic sur Mac): ouvrir le lien dans un nouvel onglet

Ajuster la taille du texte

La taille du texte est spécifiée par le pack de contenu que vous utilisez. Pour votre confort visuel, vous pouvez augmenter ou diminuer la taille du texte quand vous le souhaitez. Pour ce faire, utilisez l'icone Augmenter Zoom-in24.png pour augmenter et Diminuer Zoom-out24.png pour diminuer la taille du texte. Ces commandes sont aussi disponibles dans la barre de menu, Affichage>Zoom, ainsi que l'option Taille originale pour réinitialiser le texte à sa taille originale.

Raccourcis clavier:

  • Ctrl et + ( et + sur Mac): augmenter la taille du texte
  • Ctrl et - ( et - sur Mac): diminuer la taille du texte
  • Ctrl et 0 ( et 0 sur Mac): réinitialiser la taille du texte

Pour gagner de l'espace sur un écran réduit, il peut être souhaitable d'afficher Kiwix en mode plein écran. Pour ce faire, cliquez sur l'icône Plein écranFullscreen24.png ; pour quitter le mode plein écran, cliquez une deuxième fois sur cet icône.


Raccourci clavier: *F11 ( et Shift et F sur Mac): activer/désactiver plein écran.

Imprimer et exporter des documents

Trois options sont disponibles pour imprimer ou exporter des pages Kiwix:

  • Pour imprimer la page consultée sur Kiwix, cliquez sur l'icône Imprimer Print24.png. Cette option est également disponible dans le menu "Fichier". Vous pourrez alors prévisualiser la page et ajuster les paramètres de base de l'impression. Assurez-vous que l'imprimante soit allumée et connectée à l'ordinateur.

Raccourci clavier: Ctrl + P ( + P sur Mac): Imprimer la page actuelle

  • L'export au format PDF se fait dans le menu Fichier > Printas-pdf16.pngImprimer au format PDF. Cela convertira la page en un document PDF qui peut être imprimé ou consulté plus tard. Notez que la sortie a été préformatée pour l'impression et que les liens internes ont été supprimés de la page.

Raccourci clavier: *Ctrl + Shift + D ( + Shift + D sur Mac): Export PDF

  • L'export d'une page au format texte ou HTML se fait dans le menu Fichier > Enregistrer sous.... Bien que non approprié pour le partage, le format HTML gardera le même formatage et les liens internes de la page.

Raccourci clavier: Ctrl + S ( + S sur Mac): Export texte/HTML

Créer et utiliser des marque-pages

Vous pouvez utiliser les marques pages de Kiwix pour sauvegarder les pages que vous voulez revisiter. Les marque-pages sont organisés en groupes. Vous pouvez facilement importer/exporter un groupe de marque pages, qui est sauvegardé comme fichier sur votre ordinateur ; vous pourrez ensuite partager cette liste de pages, par exemple à vos étudiants.

Cliquez sur l'icône Marque-pages Bookmarks24.png dans la barre de menus pour ouvrir le panneau latéral de gestion des marque-pages sur la gauche de l'application.

Pour créer un nouveau groupe, cliquez sur l'icône Créer un nouveau groupe de marque-pages New24.png, puis choisissez un emplacement sur votre ordinateur ; renseignez enfin le nom.

Le groupe créé sera enregistré sous forme d'une fichier .XML, qui sera mis à jour à chaque ajout/suppression d'un marque-page. Vous pouvez utiliser ce fichier à des fins de partage ou de restauration. Pour importer un groupe de marque pages, cliquez sur l'icône Importer un groupe de marque-pages Open24.png en haut du panneau, puis sélectionnez le fichier XML concerné sur votre ordinateur.

Vous pouvez ajouter la page actuelle à votre marque-pages en cliquant sur l'icône Marquer cette page Add24.png. Celle-ci va être ajoutée augroupe de marque-pages ; vous pouvez ajouter des note au bas du panneau, Notes de marque-pages. Sélectionner un item du groupe vous amènera à ladite page. Vous pouvez supprimer cette page en cliquant sur l'icône Supprimer le marque-pages Remove24.png. Vous pouvez également changer entre vos différents groupes (celui par défaut et ceux importés) en utilisant la liste de groupes sous le panneau outils. La fermeture de Kiwix entraîne la fermeture de tous les groupes ; vous devrez donc importer à nouveau tous vos groupes la lors de la prochaine utilisation.

Raccourci clavier:

  • Ctrl + D ( + D sous Mac): Ajouter/supprimer la page actuelle du groupe

Outils d'édition

Utilisez la barre de recherche pour localiser un mot ou une phrase spécifique dans une page web. Pour faire ainsi, cliquez sur l'icône Rechercher dans la page Find-article24.png ou choisissez Éditer>Rechercher dans la page dans la barre de menu. Kiwi trouve automatiquement la page pendant que vous tapez, surlignant la correspondances actuelle (en vert), ou en montrant où se trouvent toutes les correspondances se trouvant (en rose) sur la page à l'aide de l'option Surligner tout dans la barre de recherche. Naviguez d'un résultat à l'autre à l'aide des flèches Suivant et Précédent dans la barre de recherche ; vous pouvez également activer la sensibilité à la casse dans la même barre.


Raccourci clavier:

  • Ctrl + F(⌘-H sous Mac): Rechercher dans la page

Kiwix supporte également la fonction copier-coller. Pour faire ainsi, sélectionnez le texte puis choisissez depuis le menu Édition>Copier. Vous pouvez aussi faire un clic droit, Copier, ou encore "Rechercher pour trouver le texte dans le fichier ZIM". Vous pourrez alors coller le texte sélectionné dans n'importe quelle autre application. Si vous voulez sélectionner l'intégralité du texte, choisissez dans le menu Édition>Sélectionner tout. Vous pouvez également effectuer un clic droit, puis Sélectionnez tout.

Raccourcis clavier:

  • Ctrl + C(⌘-C sur Mac): copier le texte sélectionné
  • Ctrl + A(⌘-A sur Mac): tout sélectionner

Moteur de recherche à plein texte et processus d'indexation

Utilisation de l'autocomplétion. Vous pouvez voir les titres de pages référencées avec le mot "Wikipédia", et accéder à la page désirée en cliquant sur l'item correspondant dans la liste. Vous pouvez aussi voir les pages contenant le mot "Wikipédia" en choisissant le dernier item de la liste ("contenant 'Wikipédia')..."

Kiwix inclut un moteur de recherche performant qui vous aide à accéder aisément aux pages que vous consultez et chercher une phrase dans le contenu des pages d'un paquet. Le moteur de recherche plein texte n'est disponible que pour les fichiers ZIM indexés. Donc si vous avez téléchargé des fichiers ZIM portables pré-indexés, vous pourrez utiliser cette fonctionnalité. Pour les fichiers non indexés, vous devrez tout d'abord les indexer.

Le moteur de recherche est localisé sur le côté droit de la barre d'outils. Si vous pouvez sélectionner le champ de recherche et y taper un mot, alors le moteur de recherche est prêt à être utilisé. Dans le cas contraire, Kiwix va vous demander si vous voulez indexer le fichier ZIM ou non. Vous devrez confirmer si vous voulez utiliser le moteur de recherche à plein texte ou annuler si vous voulez utilisez le programme sans cette fonctionnalité.

Cette étape prend beaucoup de temps. En fonction de la taille de votre fichier ZIM et de la vitesse de votre ordinateur, cela peut prendre plusieurs heures à plusieurs jours pour des paquets comme Wikipedia en anglais. Notez qu'il y a une différence de taille de 20 à 100% de différence entre les fichiers ZIM indexés et non-indexés et que si vous choisissez d'indexer un fichier ZIM votre ordinateur devra créer un fichier d'indexation ton la taille est égale à la différence entre les fichiers ZIM indexés et non-indexés ; veillez donc durant cette étape à ne pas fermer l'application ni éteindre votre ordinateur.

Vous pouvez voir combien de pourcents de l'indexation ont été réalisés dans la barre de progression verte dans la barre d'état (comme Indexing-progress.png) ; votre barre d'état devrait donc être active, et si ce n'est pas le cas, vous pouvez l'afficher dans le menu Affichage. Notez que vous n'aurez pas à faire ceci si vous avez téléchargé un fichier ZIM pré-indexé.

Après que cette étape soit complétée, le moteur de recherche est prêt à être utilisé. Vous aurez juste à taper du texte dans votre barre de recherche et appuyer sur Entrée. Une page incluant les résultats de recherche s'affichera et vous pourrez accéder à la page que vous voulez consulter.

Si vous ne voulez pas utiliser cette fonctionnalité, tapez simplement un mot dans la barre de recherche et vous verrez une liste des titres de pages contenant ce mot. La liste pop-up a la capacité d'autocomplétion, prédisant le mot actuellement écrit et vous suggérant le titre de page le plus proche, vous permettant de choisir celui que vous voulez en conséquence.

Plus d'options

Il y a d'autres options disponibles avec Kiwix. Vous pouvez changer la langue de l'application en choisissant Affichage>Langue dans la barre de menu et choisir la langue désirée. Vous pouvez également changer l'apparence de Kiwix en allant sur Affichage>Apparence. En choisissant Affichage>Couleurs inversées, la couleur des pages sera inversée, par exemple le texte noir deviendra blanc et l'arrière plan blanc deviendra noir.

Raccourci clavier:

  • Ctrl + I ( + I sur Mac):

Comme pour la barre latérale de Wikipedia, il y a une option nommée Select-all16.png Article au hasard, qui montre un article au hasard du contenu ZIM. Une autre option de ce menu est Purge-history16.png Effacer historique, qui supprime l'historique des pages que vous avez visitées ; les boutons Précédent/Suivant seront donc inutiles à partir de ce moment.

Si vous avez un réseau local et que vous souhaitez partager Kiwix avec des clients de ce réseau, allez dans Outils>Serveur, cliquez sur le bouton Start après avoir sélectionné le port et cliquez sur Charger. Après ceci vous aurez une application Kiwix moins fonctionnelle sur votre serveur. Plus d'informations ici: Kiwix-serve.