Tell us your story
Tell us your story
How has offline Wikipedia affected you? The Wikimedia Foundation (the non-profit that supports Wikipedia) is looking for personal, diverse and inspiring stories about how offline Wikipedia affects the world. If you have a personal story that you would like to share, please contact: stories@kiwix.org. Thank you!

Guía del usuario

From Kiwix
Jump to: navigation, search
This page is a translated version of the page User guide and the translation is 77% complete.

Other languages:
English • ‎español • ‎فارسی • ‎français • ‎magyar • ‎italiano • ‎日本語 • ‎русский • ‎中文(中国大陆)‎

Guía del usuario
Una introducción breve incluyendo información sobre las herramientas y los comandos de la aplicación.

← Volver a la página de ayuda

Botones y teclas de navegación

Explorar contenido con Kiwix es similar a los navegadores web. Fácilmente puedes ir de una página (que puede ser un documento o un artículo) a otra. Al hacer clic en el icono Inicio Home24.png verás la página de inicio de tus archivos ZIM. Por ejemplo, si usas el archivo ZIM de la Wikipedia en inglés, verás el artículo Wikipedia. Si aún no has instalado ningún archivo ZIM, verás la página de ayuda, que significa que no hay contenido que mostrar. En ese caso, deberías seguir las instrucciones de esta página.

Tal como en tu navegador web, puedes regresar a la página anterior haciendo clic en el icono de la flecha Atrás Go-back24.png e ir a la página siguiente haciendo clic en el icono de la flecha Adelante Go-forward24.png en la barra de herramientas. Para abrir una Nueva pestaña, haz clic en el icono Abrir una nueva pestaña Add24.png junto a la última pestaña en la parte superior de la ventana o presiona Ctrl+T (⌘-T en Mac). Para cerrar una pestaña, usa Close12.png en el lado derecho de cada pestaña que quieras cerrar, o bien el atajo de teclado Ctrl+W (⌘-W en Mac). Puedes abrir los enlaces de una página en una pestaña nueva presionando Ctrl en tu teclado o haciendo clic derecho en el enlace y eligiendo "Abrir el enlace en una nueva pestaña".

Ajustar el tamaño del texto

El tamaño del texto lo especifica el paquete de contenido que estas usando. Como puede no ser lo ideal para tus ojos y comodidad, puedes aumentar o disminuir el tamaño del texto de las páginas en cualquier momento. Para eso, usa el icono Ampliar Zoom-in24.png para aumentar y el icono Reducir Zoom-out24.png para disminuir el tamaño del texto. Esas opciones también están disponibles en Mostrar > Ampliación en la barra de menú. Ahí hay una opción más llamada Zoom-10016.png Tamaño original que restablece el tamaño del texto de la página a su tamaño original. También puedes usar los atajos de teclados Ctrl y + ( y + en Mac) para ampliar, Ctrl y - ( y - en Mac) para reducir y Ctrl y 0 ( y 0 en Mac) para restablecer el nivel de ampliación.

Para ganar un poco de espacio extra en una pantalla pequeña, quizás quieras usar Kiwix en modo pantalla completa. Maximizará el tamaño de la ventana de Kiwix y esconderá todos los otros programas, incluyendo tu sistema operativo. Para hacer esto, haz clic en el icono Pantalla completa Fullscreen24.png o usa el atajo de teclado F11 (⌘-Shift-F en Mac).

Imprimir y exportar documentos

Puedes imprimir las páginas en Kiwix,e incluso exportarlas y compartirlas. Hay tres opciones disponibles:

  • Para imprimir una página que estás viendo en Kiwix, haz clic en el icono Imprimir Print24.png en la barra de herramientas o presiona Ctrl+P (⌘-P en Mac). Esta opción también está disponible en el menú Archivo. Podrás ver una vista previa de la página y ajustar parámetros básicos de página e impresión antes de imprimir. Asegúrate también que esté encendida la computadora donde esté conectada la impresora.
  • Para exportar una página al formato PDF, dirígete a Archivo > Printas-pdf16.png Imprimir en formato PDF o simplemente presiona Ctrl+Shift+D (⌘-Shift-D en Mac). Convertirá la página en un archivo PDF, que puede imprimirse o leerse más tarde. Observa que el archivo resultante se preparó para imprimirse y se eliminaron los enlaces internos de la página.
  • Para guardar la página como un archivo HTML o de texto, dirígete a Archivo > Saveas16.png Guardar página como... o simplemente presiona Ctrl+S (⌘-S en Mac). Aunque no es apropiado para compartir, el formato HTML mantendrá el formato y los enlaces de la página.

Crear y usar marcadores

Puedes usar los marcadores de Kiwix para guardar fácilmente las páginas que quieras volver a visitar. Los marcadores se organiza en conjuntos, que es una lista (o grupo) de marcadores que se han juntado. Fácilmente puedes importar o exportar un conjunto entero de marcadores, que se guardan como un archivo común en tu computadora. Así puedes compartir una lista de páginas, por ejemplo con tus estudiantes.

Al hacer clic en el icono Marcadores Bookmarks24.png en la barra de herramientas se abrirá el panel de marcadores a la izquierda de la aplicación. Para crear un nuevo conjunto, haz clic en el icono Crear un conjunto de marcadores nuevo New24.png, luego elige una carpeta en tu computadora y escribe un nombre. Se guardará como un archivo .XML y cada vez que agregues o elimines un marcador al conjunto, se actualizará este archivo. Puedes compartir este archivo con quien quieras y donde quieras, ya sea para importarlo o para hacer una copia de respaldo. Si tienes un archivo de marcadores y quieres importarlo a tu Kiwix, haz clic en el icono Importar conjunto de marcadores Open24.png en la parte superior del panel, y luego selecciona el archivo .XML de tu computadora.

Puedes agregar la página actual a tu conjunto de marcadores haciendo clic en el icono Marcar esta página Add24.png o usando el atajo de teclado Ctrl+D (⌘-D en Mac). Se agregará a la lista de marcadores y también podrás escribir algunas notas relacionadas en la parte inferior del panel, Notas de marcador. Al seleccionar cada elemento de la lista, te llevará hacia esa página. Podrás eliminar ese elemento haciendo clic en el icono Desmarcar seleccionados Remove24.png. Puedes alternar entre tus conjuntos abiertos (el predeterminado y los que hayas importado) usando la lista de conjuntos de marcadores abiertos justo debajo de la barra de herramientas del panel. Cuando cierres Kiwix, se cerrarán todos tus conjuntos y deberás volver a importarlos la próxima vez.

Herramientas de edición

Usa la barra de búsqueda para buscar una palabra o frase específicas en una página. Para eso, haz clic en el icono Buscar en el texto Find-article24.png en la barra de herramientas o elije Editar > Buscar en la página en la barra de menú. También puedes usar el atajo de teclado Ctrl+F (⌘-F en Mac) para abrir rápidamente la barra de búsqueda. Mientras escribes, Kiwix encuentra automáticamente la página, resaltando con verde las posibles coincidencias. Puedes ver (en rosa) dónde están ubicadas todas las coincidencias en la página tocando el botón Resaltar todas en la barra de búsqueda. Puedes saltar entre los resultados usando Siguiente y Anterior, como también elegir Respetar mayúsculas si quieres que coincidan exactamente las mayúsculas y minúsculas.

Kiwix también admite copiar y pegar. Para hacer esto, selecciona una parte del texto con el mouse y luego elije Editar > Copy16.pngCopiar o simplemente presiona Ctrl+C (⌘-C en Mac) en tu teclado. También puedes hacer clic derecho sobre el texto y elegir "Copiar" para copiar el texto o "Buscar" para buscar el texto en el archivo ZIM. Luego podrás pegar ese texto en cualquier otro lugar. Si quieres seleccionar todo el texto de una página, elije Editar > Select-all16.png Seleccionar todo o presiona Ctrl+A (⌘-A en Mac) en tu teclado. También puedes hacer clic derecho en cualquier lugar de la página y elegir "Seleccionar todo".

Full-text search engine and Indexing process

Using search engine Autocompletion feature. You can see the page titles stared with the word "Wikipedia", and then access to the desired page by clicking on the corresponding item of the list. You can also see the pages which includes the word "Wikipedia" by choosing the last item of the list (containing 'Wikipedia'...)

Kiwix includes a powerful search engine to help you easily access the pages you are looking for and search a phrase through the content of the pages of a package. The full-text search engine is available only for the indexed ZIM files. So if you have downloaded a Portable pre-indexed ZIM file, you will be able to use this feature. But for the Non-indexed ZIM files, you should index them first.

The search engine is located on the right side of the toolbar. If you can select the search box and type a word inside that, it means your search engine is ready to use. Otherwise, Kiwix will ask you if you want to index the ZIM file or not. You will need to confirm this process in order to use the full-text search engine feature or cancel it and use the program without this feature.

This step is very time-consuming. Depending on the size of your ZIM file and the speed of your computer, might last several hours or even several days for big packages like the English Wikipedia. Note that there is a 20 to 100 percents difference in size between the indexed and non-indexed ZIM files and if you want to index a ZIM file, your computer will have to create the index files which their size is equal to the same difference of the indexed and non-indexed ZIM files, so be careful to do this process without turning your system down or closing the application.

You can also see how many percents of the indexing process has been proceeded or remained in the progressive green bar on the Status bar (like Indexing-progress.png), so your status bar should be active and do this appear that from Display menu if you can't see it now. Note that you won't need to do this long process if you download the Pre-Indexed ZIM file.

After this process is completed, the full-text search engine will be ready to use. You will just need to type a text into the search field and then press Enter on your keyboard. A page including a list of matching results will appear and you can access the one you want to view.

If you don't want to use the full-text search ability, you can just type a word in the search box and see a list of the page titles containing that word. The popup-list has the ability of Autocomplete and predicts the word being typed and suggests you the nearest page titles and you can choose the one you want subsequently.

Más opciones

Hay más opciones disponibles en Kiwix. Puedes cambiar el idioma de la aplicación eligiendo en la barra de menú Mostrar > Idioma. También puedes cambiar la apariencia de Kiwix yendo a Mostrar > Apariencia. Si eliges Mostrar > Colores invertidos o presionas Ctrl+I (⌘-I en Mac), se invertirán los colores de la página. O sea, el texto negro cambiará a blanco y el fondo blanco cambiará a negro.

Como la barra lateral de Wikipedia, existe una opción llamada Select-all16.png Artículo aleatorio en el menú Herramientas, que muestra un artículo al azar del contenido ZIM. Otra opción de este menú es Purge-history16.png Purgar el historial que vacía el historial de las páginas que has visitado y, por lo tanto, se desactivarán los botones Atrás y Adelante.

Si quieres compartir Kiwix en tu red local, debes ir a Herramientas > Servidor, elegir el puerto, hacer clic en el botón Iniciar y luego en Cargar. Obtendrás el mismo Kiwix pero con menos funcionalidades (simplemente en tu navegador web). Para más información visita Kiwix-serve.