Tell us your story
Tell us your story
How has offline Wikipedia affected you? The Wikimedia Foundation (the non-profit that supports Wikipedia) is looking for personal, diverse and inspiring stories about how offline Wikipedia affects the world. If you have a personal story that you would like to share, please contact: stories@kiwix.org. Thank you!

Mode d'emploi

From Kiwix
Revision as of 19:19, 23 May 2020 by Godpepper (talk | contribs) (Created page with "Cette étape prend beaucoup de temps. En fonction de la taille de votre fichier ZIM et de la vitesse de votre ordinateur, cela peut prendre plusieurs heures à plusieurs jours...")
Jump to: navigation, search
Other languages:
English • ‎español • ‎فارسی • ‎français • ‎magyar • ‎italiano • ‎日本語 • ‎русский • ‎中文(中国大陆)‎

Mode d'emploi
Une brève instruction incluant des informations sur les outils et commandes de l'application ...

← Retour à la page d'aide

Les touches de navigation et les boutons

La manière de parcourir le contenu de Kiwix est similaire à un navigateur web, ainsi vous pouvez facilement naviguer à partir d'une page (qui pourrait être un document ou un article) vers une autre page. Cliquez sur l’icône Page d'accueil Home24.png si vous voulez vous rendre sur la page d'accueil de votre fichier ZIM actuel. Par exemple, si vous démarrez le fichier ZIM Wikipédia en français, vous verrez l'entrée Wikipédia sur votre page d'accueil. Si vous n'avez pas encore installé un fichier ZIM, vous verrez la page d'aide sur la page d'accueil et cela signifie qu'il n'y a pas de contenu à afficher. Dans ce cas, vous devez suivre les instructions de cette page pour lire du contenu.

Comme pour votre navigateur web, vous pouvez retourner à la page précédente en cliquant sur l'icône de flèche Précédente Go-back24.png et aller à la page suivante en cliquant sur l'icône de flèche Suivante Go-forward24.png dans la barre d'outils. Pour ouvrir une page Nouvel onglet, cliquez sur l'icône Ouvrir un nouvel onglet Add24.png à côté du dernier onglet ouvert. Pour fermer un onglet, utilisez cliquez sur l'icône Close12.png sur le côté droit de l'onglet désiré. Pour ouvrir un lien vers une autre page dans un nouvel onglet, faites un clic droit sur celui-ci, et choisissez "Ouvrir dans un nouvel onglet".

Raccourcis clavier:

  • Ctrl et T ( et T sur Mac): nouvel onglet
  • Ctrl et W ( et W sur Mac): fermer l'onglet actuel
  • Ctrl pendant clic ( pendant clic sur Mac): ouvrir le lien dans un nouvel onglet

Ajuster la taille du texte

La taille du texte est spécifiée par le pack de contenu que vous utilisez. Pour votre confort visuel, vous pouvez augmenter ou diminuer la taille du texte quand vous le souhaitez. Pour ce faire, utilisez l'icone Augmenter Zoom-in24.png pour augmenter et Diminuer Zoom-out24.png pour diminuer la taille du texte. Ces commandes sont aussi disponibles dans la barre de menu, Affichage>Zoom, ainsi que l'option Taille originale pour réinitialiser le texte à sa taille originale.

Raccourcis clavier:

  • Ctrl et + ( et + sur Mac): augmenter la taille du texte
  • Ctrl et - ( et - sur Mac): diminuer la taille du texte
  • Ctrl et 0 ( et 0 sur Mac): réinitialiser la taille du texte

Pour gagner de l'espace sur un écran réduit, il peut être souhaitable d'afficher Kiwix en mode plein écran. Pour ce faire, cliquez sur l'icône Plein écranFullscreen24.png ; pour quitter le mode plein écran, cliquez une deuxième fois sur cet icône.


Raccourci clavier: *F11 ( et Shift et F sur Mac): activer/désactiver plein écran.

Imprimer et exporter des documents

Trois options sont disponibles pour imprimer ou exporter des pages Kiwix:

  • Pour imprimer la page consultée sur Kiwix, cliquez sur l'icône Imprimer Print24.png. Cette option est également disponible dans le menu "Fichier". Vous pourrez alors prévisualiser la page et ajuster les paramètres de base de l'impression. Assurez-vous que l'imprimante soit allumée et connectée à l'ordinateur.

Raccourci clavier: Ctrl + P ( + P sur Mac): Imprimer la page actuelle

  • L'export au format PDF se fait dans le menu Fichier > Printas-pdf16.pngImprimer au format PDF. Cela convertira la page en un document PDF qui peut être imprimé ou consulté plus tard. Notez que la sortie a été préformatée pour l'impression et que les liens internes ont été supprimés de la page.

Raccourci clavier: *Ctrl + Shift + D ( + Shift + D sur Mac): Export PDF

  • L'export d'une page au format texte ou HTML se fait dans le menu Fichier > Enregistrer sous.... Bien que non approprié pour le partage, le format HTML gardera le même formatage et les liens internes de la page.

Raccourci clavier: Ctrl + S ( + S sur Mac): Export texte/HTML

Créer et utiliser des marque-pages

Vous pouvez utiliser les marques pages de Kiwix pour sauvegarder les pages que vous voulez revisiter. Les marque-pages sont organisés en groupes. Vous pouvez facilement importer/exporter un groupe de marque pages, qui est sauvegardé comme fichier sur votre ordinateur ; vous pourrez ensuite partager cette liste de pages, par exemple à vos étudiants.

Cliquez sur l'icône Marque-pages Bookmarks24.png dans la barre de menus pour ouvrir le panneau latéral de gestion des marque-pages sur la gauche de l'application.

Pour créer un nouveau groupe, cliquez sur l'icône Créer un nouveau groupe de marque-pages New24.png, puis choisissez un emplacement sur votre ordinateur ; renseignez enfin le nom.

Le groupe créé sera enregistré sous forme d'une fichier .XML, qui sera mis à jour à chaque ajout/suppression d'un marque-page. Vous pouvez utiliser ce fichier à des fins de partage ou de restauration. Pour importer un groupe de marque pages, cliquez sur l'icône Importer un groupe de marque-pages Open24.png en haut du panneau, puis sélectionnez le fichier XML concerné sur votre ordinateur.

Vous pouvez ajouter la page actuelle à votre marque-pages en cliquant sur l'icône Marquer cette page Add24.png. Celle-ci va être ajoutée augroupe de marque-pages ; vous pouvez ajouter des note au bas du panneau, Notes de marque-pages. Sélectionner un item du groupe vous amènera à ladite page. Vous pouvez supprimer cette page en cliquant sur l'icône Supprimer le marque-pages Remove24.png. Vous pouvez également changer entre vos différents groupes (celui par défaut et ceux importés) en utilisant la liste de groupes sous le panneau outils. La fermeture de Kiwix entraîne la fermeture de tous les groupes ; vous devrez donc importer à nouveau tous vos groupes la lors de la prochaine utilisation.

Raccourci clavier:

  • Ctrl + D ( + D sous Mac): Ajouter/supprimer la page actuelle du groupe

Outils d'édition

Utilisez la barre de recherche pour localiser un mot ou une phrase spécifique dans une page web. Pour faire ainsi, cliquez sur l'icône Rechercher dans la page Find-article24.png ou choisissez Éditer>Rechercher dans la page dans la barre de menu. Kiwi trouve automatiquement la page pendant que vous tapez, surlignant la correspondances actuelle (en vert), ou en montrant où se trouvent toutes les correspondances se trouvant (en rose) sur la page à l'aide de l'option Surligner tout dans la barre de recherche. Naviguez d'un résultat à l'autre à l'aide des flèches Suivant et Précédent dans la barre de recherche ; vous pouvez également activer la sensibilité à la casse dans la même barre.


Raccourci clavier:

  • Ctrl + F(⌘-H sous Mac): Rechercher dans la page

Kiwix supporte également la fonction copier-coller. Pour faire ainsi, sélectionnez le texte puis choisissez depuis le menu Édition>Copier. Vous pouvez aussi faire un clic droit, Copier, ou encore "Rechercher pour trouver le texte dans le fichier ZIM". Vous pourrez alors coller le texte sélectionné dans n'importe quelle autre application. Si vous voulez sélectionner l'intégralité du texte, choisissez dans le menu Édition>Sélectionner tout. Vous pouvez également effectuer un clic droit, puis Sélectionnez tout.

Raccourcis clavier:

  • Ctrl + C(⌘-C sur Mac): copier le texte sélectionné
  • Ctrl + A(⌘-A sur Mac): tout sélectionner

Moteur de recherche à plein texte et processus d'indexation

Utilisation de l'autocomplétion. Vous pouvez voir les titres de pages référencées avec le mot "Wikipédia", et accéder à la page désirée en cliquant sur l'item correspondant dans la liste. Vous pouvez aussi voir les pages contenant le mot "Wikipédia" en choisissant le dernier item de la liste ("contenant 'Wikipédia')..."

Kiwix inclut un moteur de recherche performant qui vous aide à accéder aisément aux pages que vous consultez et chercher une phrase dans le contenu des pages d'un paquet. Le moteur de recherche plein texte n'est disponible que pour les fichiers ZIM indexés. Donc si vous avez téléchargé des fichiers ZIM portables pré-indexés, vous pourrez utiliser cette fonctionnalité. Pour les fichiers non indexés, vous devrez tout d'abord les indexer.

Le moteur de recherche est localisé sur le côté droit de la barre d'outils. Si vous pouvez sélectionner le champ de recherche et y taper un mot, alors le moteur de recherche est prêt à être utilisé. Dans le cas contraire, Kiwix va vous demander si vous voulez indexer le fichier ZIM ou non. Vous devrez confirmer si vous voulez utiliser le moteur de recherche à plein texte ou annuler si vous voulez utilisez le programme sans cette fonctionnalité.

Cette étape prend beaucoup de temps. En fonction de la taille de votre fichier ZIM et de la vitesse de votre ordinateur, cela peut prendre plusieurs heures à plusieurs jours pour des paquets comme Wikipedia en anglais. Notez qu'il y a une différence de taille de 20 à 100% de différence entre les fichiers ZIM indexés et non-indexés et que si vous choisissez d'indexer un fichier ZIM votre ordinateur devra créer un fichier d'indexation ton la taille est égale à la différence entre les fichiers ZIM indexés et non-indexés ; veillez donc durant cette étape à ne pas fermer l'application ni éteindre votre ordinateur.

You can also see how many percents of the indexing process has been proceeded or remained in the progressive green bar on the Status bar (like Indexing-progress.png), so your status bar should be active and do this appear that from Display menu if you can't see it now. Note that you won't need to do this long process if you download the Pre-Indexed ZIM file.

After this process is completed, the full-text search engine will be ready to use. You will just need to type a text into the search field and then press Enter on your keyboard. A page including a list of matching results will appear and you can access the one you want to view.

If you don't want to use the full-text search ability, you can just type a word in the search box and see a list of the page titles containing that word. The popup-list has the ability of Autocomplete and predicts the word being typed and suggests you the nearest page titles and you can choose the one you want subsequently.

More options

There are some more features available in Kiwix. You can change the language of the application to the one you want by going to Display > Language in the menu bar and choosing your desired language there. You can also change the skin of Kiwix by going to Display > Skin. By choosing Display > Inverted colors or pressing Ctrl+I (⌘-I on Mac), the colors of the page will be inverted, e.g. the black text will be white and the white background will be black, this may go along with a log in the program.

Like the sidebar of Wikipedia, there is an option named Select-all16.png Random article in the Tools menu, which shows a random article of the ZIM content. Another option of this menu is Purge-history16.png Purge history which clears the history of the pages you visited and so the Back/Forward buttons will be inactive since then.

If you have a local network and you want to share Kiwix with the clients of the network, you must go to Tools > Server, click on the Start button after selecting the port and then click on Load. Afterward, you will have the same Kiwix with less features in your network (simply in your web browser). You can read supplemental information in Kiwix-serve.