Tell us your story
Tell us your story
How has offline Wikipedia affected you? The Wikimedia Foundation (the non-profit that supports Wikipedia) is looking for personal, diverse and inspiring stories about how offline Wikipedia affects the world. If you have a personal story that you would like to share, please contact: stories@kiwix.org. Thank you!

Difference between revisions of "User guide/it"

From Kiwix
Jump to: navigation, search
(Created page with "Guida utente")
 
(Created page with "'''Guida utente'''")
Line 3: Line 3:
 
<div style="margin-bottom:8px; border:2px solid #dfdfdf; padding:1em; background-color:#bcd4e6; -moz-border-radius:15px; -webkit-border-radius:15px;">
 
<div style="margin-bottom:8px; border:2px solid #dfdfdf; padding:1em; background-color:#bcd4e6; -moz-border-radius:15px; -webkit-border-radius:15px;">
 
<big>
 
<big>
'''User Guide'''
+
'''Guida utente'''
 
<br>
 
<br>
 
A brief instruction includes information on the application's tools and commands ...  
 
A brief instruction includes information on the application's tools and commands ...  

Revision as of 14:33, 7 November 2014

Other languages:
English • ‎español • ‎فارسی • ‎français • ‎magyar • ‎italiano • ‎日本語 • ‎русский • ‎中文(中国大陆)‎

Guida utente
A brief instruction includes information on the application's tools and commands ...

← Back to help page

  • Navigation keys and buttons
Browsing Kiwix content is in a similar way as the web-browsers, so you can easily navigate from a page (which could be a document or an article) to another page. Click on the Home icon Home24.png will take you to your current ZIM file's homepage. For instance, if you run the English Wikipedia ZIM file, you will see the Wikipedia entry as its homepage. If you haven't installed any ZIM file yet, you will see the Help page as the homepage and it means there is no content to display. In that case, you should follow the instructions of this page in order to read the content.
Just like your web-browser, you can return previous page by clicking on Back arrow icon Go-back24.png and go to the next page by clicking on Forward arrow icon Go-forward24.png in the toolbar. To open the New Tab page, click on the Open a new tab icon Add24.png next the last tab at the top of window or press Ctrl+T (⌘-T on Mac). To close a tab, use the Close12.png in the right side of each tab you want to close or keyboard shortcuts Ctrl+W and (⌘-W on Mac). You can open the links of a page in a new tab, by pressing Ctrl on your keyboard or right clicking on the link and choose "Open link in new Tab" then.
  • Adjust the size of the text
The size of the text is specified by the content package you are using. Because it might not be ideal for your eyes and comfort, you can either increase or decrease the text size of the pages at any time. To do so, use the Magnify icon Zoom-in24.png to increase and Reduce icon Zoom-out24.png to decrease the size of the text. Those commands are also available in Display > Zoom on the menu bar and one more option named Zoom-10016.pngOriginal size is there which reset the text size of the page to its original size. You can also use the keyboard shortcuts Ctrl and + ( and + on Mac) to zoom in, Ctrl and - ( and - on Mac) to zoom out and Ctrl and 0 ( and 0 on Mac) to reset the zoom tool.
In order to gain some extra space on a small display, you may wish to display Kiwix in full-screen mode, it will maximize the size of the Kiwix window and hide all other programs including your operating system. In order to do this, click on full-screen icon Fullscreen24.png or use the keyboard shortcuts F11 (on Windows and Linux) and ⌘-Shift-F (on Mac).
  • Printing and exporting documents
You can print the Kiwix pages or even export them and share. There are three options available:
  1. To print a page you are viewing in Kiwix, click on Print icon Print24.png in the toolbar or press Ctrl+P (⌘-P on Mac). This option is also available in File menu. You will be able to preview the page and adjust basic printer and page settings, before printing. Make sure the computer connected to the printer is also turned on.
  2. To export a page to PDF format, go to File > Printas-pdf16.pngPrint as PDF menu item or just press Ctrl+Shift+D (⌘-Shift-D on Mac). It will convert the page into a PDF file which can be used to print or read the document later. Note that the output has been prepared for printing and the internal links will be removed from the page.
  3. To save the page as an HTML or text file, go to File > Saveas16.pngSave page as menu item or just press Ctrl+S (⌘-S on Mac). Although it is not appropriate for sharing, the HTML format will keep the same formatting and links of the page.
  • Create Bookmarks and use them
You can use Kiwix bookmarks to easily save the pages you would like to revisit. Bookmarks are organised in sets which is a list (or group) of bookmarks that has been put together. You can easily import/export a complete set of bookmarks, which is saved as a regular file on your computer, and you may wish to share a list of pages then, e.g. with your students.
Clicking on the Bookmarks icon Bookmarks24.png in the toolbar will show you the Bookmarks panel on the left side of the application. To create a new set, click on the Create new Bookmark Set icon New24.png and then choose a path on your computer and type a name. It will saved as a .XML file and each time you add or delete a bookmark to the set, this file will be updated. You can share this file with someone or somewhere else to import or backup. If you have a Bookmark file and want to import it to your Kiwix, click on Import Bookmark Set icon Open24.png in top of th panel and then select the .XML file from your computer.
You can add the current page to your bookmark set by clicking on Mark this page icon Add24.png or use the the keyboard shortcuts Ctrl+D (⌘-D on Mac). It will add to the Bookmark list and you can also write some notes for it in the bottom of the panel, Bookmark notes. Selecting each item of the list will navigate you to that page, and you may want to remove that item by clicking on Unmark selected icon Remove24.png. You can switch between your opened sets (default one and those you imported) using the combo list of opened bookmark sets below the panel toolbar. Once you close Kiwix, all your sets will be closed and you will need to import them again at the next time.
  • Edit tools
Use the find bar to locate a specific word or phrase on a webpage. To do so, click on the Find in text icon Find-article24.png in the toolbar or choose Edit > Search in page from menu bar. You can also use the keyboard shortcuts Ctrl+F (⌘-F on Mac) to quickly open the find bar. Kiwix automatically finds the page as you type, highlighting possible matches in green or see where all the matches are located on a page (in pink) by tapping on Highlight all button in the find bar. Switch between the search results using Next and Previous in the find bar and also choose Match case if you are going to have a case-sensitive search.
Kiwix also supports copy-pasting feature. In order to do that, select a part of the text using the mouse and then choose Edit > Copy16.pngCopy or just press Ctrl+C (⌘-C on Mac) from your keyboard. You can also do a right click on the text and choose "Copy" to copy the text or "Search for" to search the text in the ZIM file. Then you will be able to paste that text in any other application you want. If you want the select the whole text of a page, choose Edit > Select-all16.pngSelect all or press Ctrl+A (⌘-A on Mac) from your keyboard, and also by right clicking in everywhere of the page and choosing "Select all".


  • Full-text search engine and Indexing process
Using search engine Autocompletion feature. You can see the page titles stared with the word "Wikipedia", and then access to the desired page by clicking on the corresponding item of the list. You can also see the pages which includes the word "Wikipedia" by choosing the last item of the list (containing 'Wikipedia'...)
Kiwix includes a powerful search engine to help you easily access to the pages you are looking for and search a phrase through the content of the pages of a package. The full-text search engine is available only for the indexed ZIM files, it means if you have downloaded a Portable pre-indexed ZIM file, you will be able to use this ability. But for the Non-indexed ZIM files, you should index them first.
The search engine is located on the right side of the toolbar. If you can select the search box and type a word inside that, it means your search engine is ready to use. Otherwise, Kiwix will ask you if you want to index the ZIM file or not. You will need to confirm this process in order to use full-text search engine feature or cancel it and use the program without this feature. This step is very time-consuming process and depending on your ZIM file size and also the speed of your computer, might last several hours or even several days for big packages like English Wikipedia. Note that there is a 20 to 100 percents difference in size between the indexed and non-indexed ZIM files and if you want to index a ZIM file, your computer will have to create the index files which their size is equal to the same difference of the indexed and non-indexed ZIM files, so be careful to do this process without turning your system down or closing the application. You can also see how many percents of the indexing process has been proceeded or remained in the progressive green bar on the Status bar (like Indexing-progress.png), so your status bar should be active and do this appear that from Display menu if you can't see it now. Note that you won't need to do this long process if you download the Pre-Indexed ZIM file.
After being this process completed, the full-text search engine will be ready to use, you will just need to type a text into the search field and then press Enter on your keyboard. A page includes a list of matching results will appear and you can access the one you want to view.
If you don't want to use the full-text search ability, you can just type a word in the search box and see a list of the page titles stated with that word. The popup-list has the ability of Autocomplete and predicts the word being typed and suggests you the nearest page titles and you can choose the one you want subsequently.


  • More options
There are some more features available in Kiwix. You can change the language of the application to the one you want by going to Display > Language in the menu bar and choosing your desired language there, and also the skin of Kiwix by going to Display > Skin. By choosing Display > Inverted colors or pressing Ctrl+I (⌘-I on Mac), the colors of the page will be inverted, e.g. the black text will be white and the white background will be black, this may go along with a log in the program.
Like the sidebar of Wikipedia, there is an option named Select-all16.pngRandom article in the Tools menu, which shows a random article of the ZIM content. Another option of this menu is Purge-history16.pngPurge history which clear the history of the pages you visited and so the Back/Forward buttons will be inactive since then.
If you have a local network and you want to share Kiwix with the clients of the network, you must go to Tools > Server, click on Start button after selecting the port and then click on Load. Afterward, you will have the same Kiwix with less features in your network (simply in your web browser). You can read supplemental information in Kiwix-serve.